summaryrefslogtreecommitdiff
path: root/dev-python/dns-lexicon
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dns-lexicon')
-rw-r--r--dev-python/dns-lexicon/Manifest4
-rw-r--r--dev-python/dns-lexicon/dns-lexicon-3.7.0.ebuild59
-rw-r--r--dev-python/dns-lexicon/metadata.xml4
3 files changed, 66 insertions, 1 deletions
diff --git a/dev-python/dns-lexicon/Manifest b/dev-python/dns-lexicon/Manifest
index e019cb430850..48d0932d0e6c 100644
--- a/dev-python/dns-lexicon/Manifest
+++ b/dev-python/dns-lexicon/Manifest
@@ -1,3 +1,5 @@
DIST dns-lexicon-3.3.4.tar.gz 147008 BLAKE2B 14e0bbba48b8340ecb274c122363aef6490de539ea2c1ce7a4ba4ef19eaa69271ea22e28afd700dba0a1060b01211f8ac9a1081e21973f07abb9ca057638241c SHA512 274a1a4ffd1d767623723b6e9aee1e9f07022f3985cbc15f75cc410f477e1dcb7a674fa847119bdccab7332d058f77ef85771bd7bcdadbe2dd9483415a365a6d
+DIST dns-lexicon-3.7.0.tar.gz 7826689 BLAKE2B 920bfcd51642c12a0353dbc0ef8476c0def0c1fcf160757ce8ec47ce3516c1a2b203d2e07ef023b502b9a4e52d2fe91e9c0a73fa83337471e7669effc054a441 SHA512 aabfb2460bc2665b57552e6267846a0f2e508661dfdefbd22adca5833f32e8034198d1c3d5c33b2b89fb4a0cf0e9a84ec7d90426a6d8ba78acf2f2d0748c2d65
EBUILD dns-lexicon-3.3.4.ebuild 625 BLAKE2B 723c37b38fad26079e87f13fc99833f2f33af22682eb8b25b3f9e4d83c40c8aa1fd312f133e11b15f9c8921c125b599dcbe6bb397e90fa932934c8939d93e2e9 SHA512 0cd5aeff362c83f2ef711ac72dfaed3ffa6ac0488d31e9ec8a4dad8d725d24b4706dee9f1306832174d10266557ec2f873e99b90cbdf620cb609535cbfa3439c
-MISC metadata.xml 439 BLAKE2B 83c88e8efae9eed766a6f061446036bbf9ca1d3143257d6b23dfd4424b3c468d3a6e38727915eec05d33f070d4cec06b81948a629db542ca89b9e165dbc09f4f SHA512 4f2842cc32c0b560c6304fb2d3611cc87069c4408b095bfa6ff1ded387cfe51ac69681d6be561bd6006525116b0dcdbb9df3eea85c1fe4ef5cec25367f2eb199
+EBUILD dns-lexicon-3.7.0.ebuild 1614 BLAKE2B cf693ce1a0e557adc35e14233c05268f86c387070651a788f25b378cad2384bc1d59739762155bc7ee1d83cf27255ecc4f11857d4cdfa290ec5745b1de7de9ae SHA512 db9acbe9cf80be3e8ff0099a2306fa45c58d9cc86d6d4d865987c1556078f2434393d647b7f46197ce922779602be0061b4730668bb10da70babc22db58208c5
+MISC metadata.xml 540 BLAKE2B 4fc087289e162c8f026f5fd02e49c15f37ed5300a546fbec4d2d310ebf794e78ff294d0a8ac4388e352534733fb5e9b259c6ecee557a09296229265a8c7b8adb SHA512 87a91f36e68881f6aa629ac319fc3c4f264df5a133e4bbe96f2af13618e3f4b248e31dc1eccff56111d0f7d04ddb9d9ad1f7114cc101eeb23d905b1d5d2f3025
diff --git a/dev-python/dns-lexicon/dns-lexicon-3.7.0.ebuild b/dev-python/dns-lexicon/dns-lexicon-3.7.0.ebuild
new file mode 100644
index 000000000000..72b25fc41302
--- /dev/null
+++ b/dev-python/dns-lexicon/dns-lexicon-3.7.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Manipulate DNS records on various DNS providers in a standardized/agnostic way"
+HOMEPAGE="https://pypi.org/project/dns-lexicon/"
+SRC_URI="https://github.com/AnalogJ/lexicon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/lexicon-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Requires the "localzone" module
+ lexicon/tests/providers/test_localzone.py
+ # Requires the "softlayer" module
+ lexicon/tests/providers/test_softlayer.py
+ # Requires the "transip" module
+ lexicon/tests/providers/test_transip.py
+ # Requires the "oci" module
+ lexicon/tests/providers/test_oci.py
+ # Uses tldextract which needs Internet access to download its database
+ lexicon/tests/providers/test_auto.py
+)
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ optfeature_header \
+ "Install the following packages to enable support for additional DNS providers:"
+ optfeature Gransy dev-python/zeep
+ optfeature Route53 dev-python/boto3
+ optfeature DDNS dev-python/dnspython
+ fi
+}
diff --git a/dev-python/dns-lexicon/metadata.xml b/dev-python/dns-lexicon/metadata.xml
index cbda10550fbb..dfce4385b8a7 100644
--- a/dev-python/dns-lexicon/metadata.xml
+++ b/dev-python/dns-lexicon/metadata.xml
@@ -5,6 +5,10 @@
<email>patrick@gentoo.org</email>
<name>Patrick Lauer</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<upstream>
<remote-id type="pypi">dns-lexicon</remote-id>
<remote-id type="github">AnalogJ/lexicon</remote-id>