summaryrefslogtreecommitdiff
path: root/dev-python/django-timezone-field
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-timezone-field')
-rw-r--r--dev-python/django-timezone-field/Manifest2
-rw-r--r--dev-python/django-timezone-field/django-timezone-field-7.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/django-timezone-field/Manifest b/dev-python/django-timezone-field/Manifest
index 995581ba98b1..167fcc63c154 100644
--- a/dev-python/django-timezone-field/Manifest
+++ b/dev-python/django-timezone-field/Manifest
@@ -1,3 +1,5 @@
DIST django-timezone-field-6.1.0.gh.tar.gz 36029 BLAKE2B 5177b440e0537fbde12e0dd4bf92e65c983996f7ef1393212b0f4c24efecfc0d4d24e1bbc8447295b565d8b9921c0c05f6cc4baa11db3ccc9b60c33c48e76fb2 SHA512 b070e55a2a5196de1fcae4bd19979caf9d84c234a4e379d82dab843541cf99a0acced9a6996e35afe6b40d1bf737d522d34b91df10596e7365f85cfbe0597015
+DIST django-timezone-field-7.0.gh.tar.gz 37416 BLAKE2B a0420ccbcb9d7d834e65d0cc89fd83662bd4b3773f1443f05866381d6bbeacba86bdd2e6078a3819bdbf6c174e3ede08e4b9d307838d5082e7bef037ff751681 SHA512 9a96b65a7dce48f58c3915e835e92b8d884f6b15f8314f5d6f1a34bc75ad4bc8f0c33035a4844b5906b7d6bc468cf364be8c82843f3af714a59dc9a40e71f9af
EBUILD django-timezone-field-6.1.0.ebuild 898 BLAKE2B 5da8e160226cb702dc7210ed73fd98dd3cd89555e1fbcfead8f5eb24ad4857d4f180db7ae7f440da1733938562094df58ff54681950fb2b5cce455232116f6a9 SHA512 8cefb9f995a825ae827f8ce2129fa62a90c242eac087cb7ac4fe150b347aae72086b7469686b08887e716780de052f90dbb1393b5a67228e9616285981b5fb2d
+EBUILD django-timezone-field-7.0.ebuild 1175 BLAKE2B 4b2a1852ae845dbcca51161264f278ef223aad4641fcf69b66a37fdd026248f26836ed5eff6000ddec5355acd9f05864494b0724ff6cf864e758b49aed791a0e SHA512 bd80ef3ec9a1562ad6b72620d7e0678a4deebb8e001c3c57f97a5ee441f53b70a8b6e9b11cfc6b4eafbbf1d892dc988d203dfe3b71a7b51f22e6cdb0c257aab6
MISC metadata.xml 417 BLAKE2B 8169aa146e3ea17598ed401420f9504deccb4fdf4faea57678073d7fcbf7cf4062aaf4e00d4c2eb80a29276b298b144d013b8baedc8b5277ff30bc65dff4f8c4 SHA512 09c5d7dcbf44b72631d63dcbc98e4dd203c28f24ffb5d5e833f6c36e641b4360b096ace62e12faff182fc26fd60fd5f4f9eb3ebf3e463fd0d1afc66fe9a70e6f
diff --git a/dev-python/django-timezone-field/django-timezone-field-7.0.ebuild b/dev-python/django-timezone-field/django-timezone-field-7.0.ebuild
new file mode 100644
index 000000000000..8027c2a3c7b6
--- /dev/null
+++ b/dev-python/django-timezone-field/django-timezone-field-7.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django app providing database and form fields for timezone objects"
+HOMEPAGE="
+ https://github.com/mfogel/django-timezone-field/
+ https://pypi.org/project/django-timezone-field/
+"
+SRC_URI="
+ https://github.com/mfogel/django-timezone-field/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ <dev-python/django-6[${PYTHON_USEDEP}]
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/djangorestframework[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-lazy-fixtures[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # https://github.com/mfogel/django-timezone-field/pull/138
+ sed -e 's:from pytest_lazyfixture import lazy_fixture:from pytest_lazy_fixtures import lf as lazy_fixture:' \
+ -i tests/*.py || die
+}
+
+python_test() {
+ local -x DB_ENGINE=sqlite
+ epytest
+}