summaryrefslogtreecommitdiff
path: root/dev-python/django-timezone-field/django-timezone-field-7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-timezone-field/django-timezone-field-7.0.ebuild')
-rw-r--r--dev-python/django-timezone-field/django-timezone-field-7.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/django-timezone-field/django-timezone-field-7.0.ebuild b/dev-python/django-timezone-field/django-timezone-field-7.0.ebuild
new file mode 100644
index 000000000000..8027c2a3c7b6
--- /dev/null
+++ b/dev-python/django-timezone-field/django-timezone-field-7.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django app providing database and form fields for timezone objects"
+HOMEPAGE="
+ https://github.com/mfogel/django-timezone-field/
+ https://pypi.org/project/django-timezone-field/
+"
+SRC_URI="
+ https://github.com/mfogel/django-timezone-field/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ <dev-python/django-6[${PYTHON_USEDEP}]
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/djangorestframework[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-lazy-fixtures[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # https://github.com/mfogel/django-timezone-field/pull/138
+ sed -e 's:from pytest_lazyfixture import lazy_fixture:from pytest_lazy_fixtures import lf as lazy_fixture:' \
+ -i tests/*.py || die
+}
+
+python_test() {
+ local -x DB_ENGINE=sqlite
+ epytest
+}