summaryrefslogtreecommitdiff
path: root/dev-python/django-registration/django-registration-3.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-registration/django-registration-3.3-r1.ebuild')
-rw-r--r--dev-python/django-registration/django-registration-3.3-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/django-registration/django-registration-3.3-r1.ebuild b/dev-python/django-registration/django-registration-3.3-r1.ebuild
new file mode 100644
index 000000000000..ae512f2de161
--- /dev/null
+++ b/dev-python/django-registration/django-registration-3.3-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="user-registration application for Django"
+HOMEPAGE="
+ https://pypi.org/project/django-registration/
+ https://github.com/ubernostrum/django-registration/
+"
+SRC_URI="
+ https://github.com/ubernostrum/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/confusable_homoglyphs[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${EPYTHON}" runtests.py \
+ || die "Tests failed with ${EPYTHON}"
+}