summaryrefslogtreecommitdiff
path: root/dev-python/django-mptt
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-mptt')
-rw-r--r--dev-python/django-mptt/Manifest3
-rw-r--r--dev-python/django-mptt/django-mptt-0.13.ebuild31
-rw-r--r--dev-python/django-mptt/files/django-mptt-0.13-test-install.patch26
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/django-mptt/Manifest b/dev-python/django-mptt/Manifest
index 33620bce8f79..e3d79e0b7f66 100644
--- a/dev-python/django-mptt/Manifest
+++ b/dev-python/django-mptt/Manifest
@@ -1,3 +1,6 @@
+AUX django-mptt-0.13-test-install.patch 606 BLAKE2B 06e54fa6c93c2efda52f73d6cf0cf02fb07cda7ccf5a131664143852862a220d77d49ff39c0f0bb63ad47811f356c347be19dc78a3f6cfe24f20ffff32639686 SHA512 01836b1c45be264f24ee584c7736502f3f31982321f3a5c77481eb7214ab7505427c346392cc3f8a79fd0f74e45853d64708e03a1df9fd47ac5721a13ae8419d
DIST django-mptt-0.11.0.tar.gz 98300 BLAKE2B cbae24143007dfe8913aacf4cbe22bbccdf929617adc31640c2d429d6ea8be727a937be0aa8353e82862b9fe8c571397db4dd3877015eb17c2c5a56172cc66a5 SHA512 21af30007661db1474628b6f8af86a3f6de52494efe1aaf9235f8b1660ba153f0de3ad91ff979588e4b681b00b44652a05146df7d3951d6ee62da38a1900fd89
+DIST django-mptt-0.13.gh.tar.gz 302525 BLAKE2B 21b2fde5c81d83321bf7569d2064db87aec3c184f27cf3fc3bd34421be04212188e15f79a575b08aabb3a7b95d116bf3e5f0fb57c56cadf9ad2ac166e8e77845 SHA512 63dbb61dab59d42b5e747f35370a0840d40ed465979d1f93e66561cf4c0726635cae774f87e39cc1ac480847f3ccf0eb65dc8593759a0860d586e334fdd37256
EBUILD django-mptt-0.11.0.ebuild 530 BLAKE2B 6ec476ce4451ae16c49a0896992047fcb22177a3d54eb0e38aedca6814e0af90531285aa9a2e28e08dc1cc4c321ca2e196d5acd31bb21d591b2d4a30d559e6bb SHA512 6fc8d461af1f778e8d240bfaed4378d4b7b6993f28b209a2c74a158ee8ba12add77684063df6e1b1e09082eaee2f1d2ae343e1692445e14ff12aded46944f3e7
+EBUILD django-mptt-0.13.ebuild 709 BLAKE2B 84b11240e817eb37b07a58acb6e7e5a2ced2e52f78505025ea6a3e49a22cdc78e4ec35847008066614fe449ee8780b6152e8743459d2dcc4e06fb7701a2d30d0 SHA512 8b71c5828c81212452be273b75de55d35f12725520aa88c372511cada83307f6771505095320d5daf0ac16ae08f6b0980bac12d908847b3a88ef65f8d1e81aa1
MISC metadata.xml 241 BLAKE2B bad9f760dafaea022669e7b898724926b5d06aae0cf9bccbf622f39c175f3391b900c17da4d5c8764702a0bcdf6d4a3b016dfc9aabe8875c384822d5df18474a SHA512 ddf81ebb9c853811cf273bdc71b4afaf7f30fa2116d53a87bbaebe0a67f7a29f1b371607e38b713750823f3afae609aab7d6bfc79c4d3762d228e7f2f8332b5c
diff --git a/dev-python/django-mptt/django-mptt-0.13.ebuild b/dev-python/django-mptt/django-mptt-0.13.ebuild
new file mode 100644
index 000000000000..584beed17861
--- /dev/null
+++ b/dev-python/django-mptt/django-mptt-0.13.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="utilities for modified preorder tree traversal and trees of model instances"
+HOMEPAGE="https://github.com/django-mptt/django-mptt"
+SRC_URI="
+ https://github.com/django-mptt/django-mptt/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/django-1.11[${PYTHON_USEDEP}]
+ dev-python/django-js-asset[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-test-install.patch
+)
+
+python_test() {
+ "${EPYTHON}" tests/manage.py test -v2 myapp ||
+ die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/django-mptt/files/django-mptt-0.13-test-install.patch b/dev-python/django-mptt/files/django-mptt-0.13-test-install.patch
new file mode 100644
index 000000000000..886d5c6e4ebd
--- /dev/null
+++ b/dev-python/django-mptt/files/django-mptt-0.13-test-install.patch
@@ -0,0 +1,26 @@
+From 6bc5860575d491e8cf1edbabee7b07f1c072bdba Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sat, 21 Aug 2021 09:45:45 +0200
+Subject: [PATCH] Do not install tests.myapp
+
+Fix options.packages.find.exclude to cover subpackages of "tests"
+recursively. Otherwise, tests.myapp is installed.
+---
+ setup.cfg | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/setup.cfg b/setup.cfg
+index b4094dc..b8ebee3 100644
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -44,6 +44,7 @@ tests =
+ [options.packages.find]
+ exclude =
+ tests
++ tests.*
+ myapp
+
+ [flake8]
+--
+2.33.0
+