summaryrefslogtreecommitdiff
path: root/dev-python/django-haystack/django-haystack-3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-haystack/django-haystack-3.0.ebuild')
-rw-r--r--dev-python/django-haystack/django-haystack-3.0.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/django-haystack/django-haystack-3.0.ebuild b/dev-python/django-haystack/django-haystack-3.0.ebuild
deleted file mode 100644
index 361da68342d2..000000000000
--- a/dev-python/django-haystack/django-haystack-3.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Pluggable search for Django"
-HOMEPAGE="https://haystacksearch.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc"
-
-RDEPEND=">=dev-python/django-2.2[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- "
-
-# tests have too many dependencies to maintain
-RESTRICT="test"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}