summaryrefslogtreecommitdiff
path: root/dev-python/django-debug-toolbar
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-debug-toolbar')
-rw-r--r--dev-python/django-debug-toolbar/Manifest2
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-3.2.2.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/django-debug-toolbar/Manifest b/dev-python/django-debug-toolbar/Manifest
index 9ef697b0bec8..59c795e6f9da 100644
--- a/dev-python/django-debug-toolbar/Manifest
+++ b/dev-python/django-debug-toolbar/Manifest
@@ -1,3 +1,5 @@
DIST django-debug-toolbar-3.2.1.tar.gz 231177 BLAKE2B b07ed03a92b5799dafd1b15b41335c5da6994be1001b579c85e0923ccc092e617ce04c9a2f4344716213cdd62425737838a8539ca5b566928bf8b4c133e8451e SHA512 d28e13cc2e3bbb27e9c728037229adac444180e3831b88c9ac1aa0e139bd1e85f9190c7a324afe3292bde4ad0c919bd17fbde4998be266f81314b9b22c4a28e6
+DIST django-debug-toolbar-3.2.2.tar.gz 239313 BLAKE2B 0e53709a3857cefc0ff7a7176ca248891122b2d758264c32171198a22b0c105af414eaba0095b1435b4f071120038f4665bd84438d77a8f65156c056d523f60f SHA512 df1956d63e88d3cf9f831609b6191446a162afbf396cb6d20e5a42aab4276ab385943cc305cad58a9f388382b0dffabc8baedf2150182a4302e7da58ab3d6a5c
EBUILD django-debug-toolbar-3.2.1.ebuild 962 BLAKE2B 4c19b67f4401317503f3aa38eb4362b04c66be04a3706d5a9f3ba08c2905dbfc6b63e8a324118a4d2762f96e859eb77deaedb6e9cab56157e2d5434469dbda14 SHA512 190e91eac002f1dbbfc195e968642c1b26637038350c54d144f6079708a611b498feccc65dfa69f9d48e2590cc4963b9b122992a02e698f43c5eb8e0fbc9b8e5
+EBUILD django-debug-toolbar-3.2.2.ebuild 981 BLAKE2B 2f1284025104260aab12628d4c4439d5af244effd4ea4e8103535e99e5900ea90c23c0a369f98ae83e427259800568f4710f614ca43c93a2492460a44a49f7a4 SHA512 6866794d7e23eabd6222b8b262e0a562229a6ebe228aeb02da0fdcb8b3ca83dbda0f95eaae5658c4a8eaf54a0ede6f4d1f2c4f723272dcb1cc17875f39f513a0
MISC metadata.xml 392 BLAKE2B 69de466f8b461389463725f2ac42881a0e0b17b2242d6dccfc045593b9feb03a0650c7e9961845298c410ac81dfbc30b9387bec3e0574765c59acb8d3256e737 SHA512 f85001a94daa2890ea28e87ecf6b6233f905141ebbb9af29087bf42a91f72f0cc7458474e84ae1ea80fd854252cfb2bb305576ad2a25ce5e36cf823caddaafd6
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-3.2.2.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-3.2.2.ebuild
new file mode 100644
index 000000000000..f64d97c58419
--- /dev/null
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-3.2.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A configurable set of panels that display debug information"
+HOMEPAGE="
+ https://pypi.org/project/django-debug-toolbar/
+ https://github.com/jazzband/django-debug-toolbar/"
+SRC_URI="
+ https://github.com/jazzband/django-debug-toolbar/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-1.11[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.2.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ ${RDEPEND}
+ )
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ emake TEST_ARGS='-v 2 tests' test
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}