summaryrefslogtreecommitdiff
path: root/dev-python/django-configurations/django-configurations-2.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-configurations/django-configurations-2.5.ebuild')
-rw-r--r--dev-python/django-configurations/django-configurations-2.5.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/django-configurations/django-configurations-2.5.ebuild b/dev-python/django-configurations/django-configurations-2.5.ebuild
deleted file mode 100644
index 74ebf3b12c3e..000000000000
--- a/dev-python/django-configurations/django-configurations-2.5.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2021-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A helper for organizing Django settings"
-HOMEPAGE="
- https://pypi.org/project/django-configurations/
- https://github.com/jazzband/django-configurations/
- https://django-configurations.readthedocs.io/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~riscv ~sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/django-3.2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/django-cache-url[${PYTHON_USEDEP}]
- dev-python/dj-database-url[${PYTHON_USEDEP}]
- dev-python/dj-email-url[${PYTHON_USEDEP}]
- dev-python/dj-search-url[${PYTHON_USEDEP}]
- )
-"
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- local -x DJANGO_SETTINGS_MODULE=tests.settings.main
- local -x DJANGO_CONFIGURATION=Test
- PYTHONPATH=. django-cadmin test -v2 || die "Tests failed with ${EPYTHON}"
-}