summaryrefslogtreecommitdiff
path: root/dev-python/discogs-client/discogs-client-2.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/discogs-client/discogs-client-2.5.ebuild')
-rw-r--r--dev-python/discogs-client/discogs-client-2.5.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/discogs-client/discogs-client-2.5.ebuild b/dev-python/discogs-client/discogs-client-2.5.ebuild
deleted file mode 100644
index 259b45e3f147..000000000000
--- a/dev-python/discogs-client/discogs-client-2.5.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://github.com/joalla/discogs_client.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/p/python3-${PN}/python3-${P}.tar.gz"
- KEYWORDS="amd64 ~x86"
- S="${WORKDIR}/python3-${P}"
-fi
-
-DESCRIPTION="Continuation of the official Python API client for Discogs"
-HOMEPAGE="
- https://github.com/joalla/discogs_client/
- https://pypi.org/project/python3-discogs-client/
-"
-
-LICENSE="BSD-2"
-SLOT="0"
-
-RDEPEND="
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/oauthlib[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests unittest