summaryrefslogtreecommitdiff
path: root/dev-python/dirty-equals
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dirty-equals')
-rw-r--r--dev-python/dirty-equals/Manifest5
-rw-r--r--dev-python/dirty-equals/dirty-equals-0.3.ebuild40
-rw-r--r--dev-python/dirty-equals/dirty-equals-0.4.ebuild40
-rw-r--r--dev-python/dirty-equals/metadata.xml11
4 files changed, 96 insertions, 0 deletions
diff --git a/dev-python/dirty-equals/Manifest b/dev-python/dirty-equals/Manifest
new file mode 100644
index 000000000000..338a9e0b8b22
--- /dev/null
+++ b/dev-python/dirty-equals/Manifest
@@ -0,0 +1,5 @@
+DIST dirty-equals-0.3.gh.tar.gz 41665 BLAKE2B af46fb9b7f0e0eb6aba09e682db73b8eef4ab9d73523cf81fb510c093cbaaa18f87c9666094aa05031eda1c32374113bc59b404ab987472821aa21ef135c038d SHA512 b6bf9a241abdbf9f74dec6efa48a23d3a665910d964947b4583127930e940001600b410d524ab1ac48c75a030f1a37528a8dbce30e982f09f913b2b3afca77f1
+DIST dirty-equals-0.4.gh.tar.gz 41864 BLAKE2B 0b916d37b323e9f587a977b46415432bc11367a6d0c95ac49e47fe604b3ee16c26eaecbbe74464076834c6186f5f0eecc049b211699a3f515ef7fdadc492537a SHA512 f98fa8c9850f26efc44dc2c5cc0ea6d687c07b49980c3eeaa71eaae78930e418c03bb35cb88aab065905443fa354b9b05d44a588458ed37d140d376b943c9da9
+EBUILD dirty-equals-0.3.ebuild 776 BLAKE2B f0d775faf58bac10a7dc9e1c6be44884a95c2ce2d052805ed4e26d738a46dc859859fec7e35b4f47684c649ff95ee7d3fd11974063050f34bafe8f68970aee1c SHA512 a583ccdb036e2dcd1613f2068e192e62b90c2abee979823c70881a4ccf969b498f89300317b2dce1665b09fcf3aa3c1314720ce03d81dc4a85118f871ca2c0a8
+EBUILD dirty-equals-0.4.ebuild 782 BLAKE2B 946e60ac2eeeb00f2d6cd7480d3ed4445f6364278cd8634301c6589664e53b0bbc92c31db6fc90354720542a5a883369e970f47718db83e50397e0f6c2f45592 SHA512 ab2d44c3aa6e631faa1a13e695649c50cf4c211afcd9f394e3a8e5657894120903ed1776c4125670212fe7a0fd58e49a1680f732fc453f3a323f9ce6723b6d0e
+MISC metadata.xml 359 BLAKE2B 120f82faf2460b2528927b708a41b2d105248a57af2f3f11966b102237731f9dab87962069728dd78327757c190790f01646c94c228d0e79bf60fbab82e1ca39 SHA512 fb17ee5e8483cd6c5ce840c2f070601c4506b0d62a8c6a80338e8748e57bfb49ee412faf7b95f21c16e5c5730efb9879d8d66fd4fd1c134ca459af3657994f98
diff --git a/dev-python/dirty-equals/dirty-equals-0.3.ebuild b/dev-python/dirty-equals/dirty-equals-0.3.ebuild
new file mode 100644
index 000000000000..eda6ad1e2ee0
--- /dev/null
+++ b/dev-python/dirty-equals/dirty-equals-0.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Doing dirty (but extremely useful) things with equals"
+HOMEPAGE="
+ https://dirty-equals.helpmanual.io/
+ https://github.com/samuelcolvin/dirty-equals/
+ https://pypi.org/project/dirty-equals/
+"
+SRC_URI="
+ https://github.com/samuelcolvin/dirty-equals/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pytz-2021.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x TZ=UTC
+ epytest
+}
diff --git a/dev-python/dirty-equals/dirty-equals-0.4.ebuild b/dev-python/dirty-equals/dirty-equals-0.4.ebuild
new file mode 100644
index 000000000000..2f8a22f1ddcc
--- /dev/null
+++ b/dev-python/dirty-equals/dirty-equals-0.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Doing dirty (but extremely useful) things with equals"
+HOMEPAGE="
+ https://dirty-equals.helpmanual.io/
+ https://github.com/samuelcolvin/dirty-equals/
+ https://pypi.org/project/dirty-equals/
+"
+SRC_URI="
+ https://github.com/samuelcolvin/dirty-equals/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pytz-2021.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x TZ=UTC
+ epytest
+}
diff --git a/dev-python/dirty-equals/metadata.xml b/dev-python/dirty-equals/metadata.xml
new file mode 100644
index 000000000000..569f65cd7a6b
--- /dev/null
+++ b/dev-python/dirty-equals/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">samuelcolvin/dirty-equals</remote-id>
+ <remote-id type="pypi">dirty-equals</remote-id>
+ </upstream>
+</pkgmetadata>