summaryrefslogtreecommitdiff
path: root/dev-python/dirty-equals/dirty-equals-0.6.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dirty-equals/dirty-equals-0.6.0-r2.ebuild')
-rw-r--r--dev-python/dirty-equals/dirty-equals-0.6.0-r2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/dirty-equals/dirty-equals-0.6.0-r2.ebuild b/dev-python/dirty-equals/dirty-equals-0.6.0-r2.ebuild
new file mode 100644
index 000000000000..fafe05d93593
--- /dev/null
+++ b/dev-python/dirty-equals/dirty-equals-0.6.0-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Doing dirty (but extremely useful) things with equals"
+HOMEPAGE="
+ https://dirty-equals.helpmanual.io/
+ https://github.com/samuelcolvin/dirty-equals/
+ https://pypi.org/project/dirty-equals/
+"
+SRC_URI="
+ https://github.com/samuelcolvin/dirty-equals/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="
+ <dev-python/pydantic-2[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2021.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # require unpackaged pytest-examples
+ tests/test_docs.py
+ )
+
+ local -x TZ=UTC
+ epytest
+}