summaryrefslogtreecommitdiff
path: root/dev-python/dill/dill-0.3.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dill/dill-0.3.4-r1.ebuild')
-rw-r--r--dev-python/dill/dill-0.3.4-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/dill/dill-0.3.4-r1.ebuild b/dev-python/dill/dill-0.3.4-r1.ebuild
new file mode 100644
index 000000000000..7adc8ad7e0e1
--- /dev/null
+++ b/dev-python/dill/dill-0.3.4-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Serialize all of python (almost)"
+HOMEPAGE="https://pypi.org/project/dill/"
+SRC_URI="
+ https://github.com/uqfoundation/dill/archive/${P}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${PN}-${P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~ppc ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ local fail= t
+ for t in tests/test_*.py; do
+ ebegin "\t${t}"
+ "${EPYTHON}" "${t}"
+ eend ${?} || fail=1
+ done
+
+ [[ ${fail} ]] && die "Tests fail with ${EPYTHON}"
+}