summaryrefslogtreecommitdiff
path: root/dev-python/dict2xml/dict2xml-1.7.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dict2xml/dict2xml-1.7.2.ebuild')
-rw-r--r--dev-python/dict2xml/dict2xml-1.7.2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/dict2xml/dict2xml-1.7.2.ebuild b/dev-python/dict2xml/dict2xml-1.7.2.ebuild
new file mode 100644
index 000000000000..c4fdd02aa09a
--- /dev/null
+++ b/dev-python/dict2xml/dict2xml-1.7.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Small utility to convert a python dictionary into an XML string"
+HOMEPAGE="https://pypi.org/project/dict2xml/ https://github.com/delfick/python-dict2xml"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# dict2xml uses noseOfYeti for its test, which is not yet available.
+RESTRICT="test"
+
+distutils_enable_tests pytest