summaryrefslogtreecommitdiff
path: root/dev-python/deprecated/deprecated-1.2.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/deprecated/deprecated-1.2.10.ebuild')
-rw-r--r--dev-python/deprecated/deprecated-1.2.10.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-python/deprecated/deprecated-1.2.10.ebuild b/dev-python/deprecated/deprecated-1.2.10.ebuild
index a5088d2c205c..b2b1fcd65d1d 100644
--- a/dev-python/deprecated/deprecated-1.2.10.ebuild
+++ b/dev-python/deprecated/deprecated-1.2.10.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
inherit distutils-r1
DESCRIPTION="Python @deprecated decorator to deprecate old API"
@@ -15,6 +15,9 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="dev-python/wrapt[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${P}-py39.patch
+)