summaryrefslogtreecommitdiff
path: root/dev-python/dep-logic/dep-logic-0.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dep-logic/dep-logic-0.1.0.ebuild')
-rw-r--r--dev-python/dep-logic/dep-logic-0.1.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/dep-logic/dep-logic-0.1.0.ebuild b/dev-python/dep-logic/dep-logic-0.1.0.ebuild
new file mode 100644
index 000000000000..58158724015e
--- /dev/null
+++ b/dev-python/dep-logic/dep-logic-0.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python dependency specifications supporting logical operations"
+HOMEPAGE="
+ https://github.com/pdm-project/dep-logic/
+ https://pypi.org/project/dep-logic/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ >=dev-python/packaging-22[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest