summaryrefslogtreecommitdiff
path: root/dev-python/denonavr/denonavr-0.11.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/denonavr/denonavr-0.11.6.ebuild')
-rw-r--r--dev-python/denonavr/denonavr-0.11.6.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/denonavr/denonavr-0.11.6.ebuild b/dev-python/denonavr/denonavr-0.11.6.ebuild
new file mode 100644
index 000000000000..ed574fb2699c
--- /dev/null
+++ b/dev-python/denonavr/denonavr-0.11.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Automation Library for Denon AVR receivers"
+HOMEPAGE="
+ https://github.com/ol-iver/denonavr/
+ https://pypi.org/project/denonavr/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/asyncstdlib-3.10.2[${PYTHON_USEDEP}]
+ >=dev-python/attrs-21.2.0[${PYTHON_USEDEP}]
+ >=dev-python/defusedxml-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/ftfy-6.1.1[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.23.1[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.11.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-4.0.2[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest