summaryrefslogtreecommitdiff
path: root/dev-python/denonavr/denonavr-0.11.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/denonavr/denonavr-0.11.0.ebuild')
-rw-r--r--dev-python/denonavr/denonavr-0.11.0.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/denonavr/denonavr-0.11.0.ebuild b/dev-python/denonavr/denonavr-0.11.0.ebuild
deleted file mode 100644
index d5846bc80fc7..000000000000
--- a/dev-python/denonavr/denonavr-0.11.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-PYTHON_REQ_USE="xml(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Automation Library for Denon AVR receivers"
-HOMEPAGE="
- https://github.com/ol-iver/denonavr/
- https://pypi.org/project/denonavr/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-python/asyncstdlib-3.10.2[${PYTHON_USEDEP}]
- >=dev-python/attrs-21.2.0[${PYTHON_USEDEP}]
- dev-python/defusedxml[${PYTHON_USEDEP}]
- >=dev-python/httpx-0.21.0[${PYTHON_USEDEP}]
- >=dev-python/netifaces-0.11.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-httpx[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_install() {
- distutils-r1_python_install
- # https://github.com/ol-iver/denonavr/pull/240
- rm -r "${D}$(python_get_sitedir)/tests" || die
-}