summaryrefslogtreecommitdiff
path: root/dev-python/defcon/defcon-0.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/defcon/defcon-0.6.0.ebuild')
-rw-r--r--dev-python/defcon/defcon-0.6.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/defcon/defcon-0.6.0.ebuild b/dev-python/defcon/defcon-0.6.0.ebuild
new file mode 100644
index 000000000000..d30040be8979
--- /dev/null
+++ b/dev-python/defcon/defcon-0.6.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="A set of UFO based objects for use in font editing applications"
+HOMEPAGE="https://github.com/typesupply/defcon"
+SRC_URI="https://github.com/typesupply/defcon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-python/fonttools-3.31.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+python_test() {
+ esetup.py test
+}