summaryrefslogtreecommitdiff
path: root/dev-python/defcon/defcon-0.5.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/defcon/defcon-0.5.3.ebuild')
-rw-r--r--dev-python/defcon/defcon-0.5.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/defcon/defcon-0.5.3.ebuild b/dev-python/defcon/defcon-0.5.3.ebuild
new file mode 100644
index 000000000000..08be7e8bd1fb
--- /dev/null
+++ b/dev-python/defcon/defcon-0.5.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="A set of UFO based objects for use in font editing applications"
+HOMEPAGE="https://github.com/typesupply/defcon"
+SRC_URI="https://github.com/typesupply/defcon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-python/fonttools[${PYTHON_USEDEP}]
+ dev-python/ufoLib[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ esetup.py test
+}