summaryrefslogtreecommitdiff
path: root/dev-python/deepdiff/deepdiff-7.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/deepdiff/deepdiff-7.0.1.ebuild')
-rw-r--r--dev-python/deepdiff/deepdiff-7.0.1.ebuild18
1 files changed, 17 insertions, 1 deletions
diff --git a/dev-python/deepdiff/deepdiff-7.0.1.ebuild b/dev-python/deepdiff/deepdiff-7.0.1.ebuild
index 70d5e8a3222a..6f08b38d1d7c 100644
--- a/dev-python/deepdiff/deepdiff-7.0.1.ebuild
+++ b/dev-python/deepdiff/deepdiff-7.0.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1 pypi
@@ -37,3 +37,19 @@ DEPEND="
"
distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # changed exception message
+ "tests/test_command.py::TestCommands::test_diff_command[t1_corrupt.json-t2.json-Expecting property name enclosed in double quotes-1]"
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}