summaryrefslogtreecommitdiff
path: root/dev-python/decorator/decorator-4.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/decorator/decorator-4.3.0.ebuild')
-rw-r--r--dev-python/decorator/decorator-4.3.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/decorator/decorator-4.3.0.ebuild b/dev-python/decorator/decorator-4.3.0.ebuild
new file mode 100644
index 000000000000..3e02054bc9f2
--- /dev/null
+++ b/dev-python/decorator/decorator-4.3.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simplifies the usage of decorators for the average programmer"
+HOMEPAGE="https://github.com/micheles/decorator https://pypi.org/project/decorator/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( docs/README.rst )
+
+python_test() {
+ "${PYTHON}" src/tests/test.py || die "Tests fail with ${EPYTHON}"
+}