summaryrefslogtreecommitdiff
path: root/dev-python/dbus-python/dbus-python-1.2.16-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dbus-python/dbus-python-1.2.16-r1.ebuild')
-rw-r--r--dev-python/dbus-python/dbus-python-1.2.16-r1.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-python/dbus-python/dbus-python-1.2.16-r1.ebuild b/dev-python/dbus-python/dbus-python-1.2.16-r1.ebuild
index 2a6f8bd59269..dc7eb8eeea93 100644
--- a/dev-python/dbus-python/dbus-python-1.2.16-r1.ebuild
+++ b/dev-python/dbus-python/dbus-python-1.2.16-r1.ebuild
@@ -3,13 +3,13 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7..10} )
PYTHON_REQ_USE="threads(+)"
inherit autotools python-r1
DESCRIPTION="Python bindings for the D-Bus messagebus"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/DBusBindings https://dbus.freedesktop.org/doc/dbus-python/"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/DBusBindings/ https://dbus.freedesktop.org/doc/dbus-python/"
SRC_URI="https://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
LICENSE="MIT"
@@ -28,7 +28,10 @@ RDEPEND="${PYTHON_DEPS}
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
- doc? ( $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]') )
+ doc? ( $(python_gen_any_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ ') )
test? ( dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/tappy[${PYTHON_USEDEP}] )
"
@@ -37,6 +40,7 @@ PATCHES=( "${FILESDIR}/${P}-py39.patch" )
python_check_deps() {
has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+ has_version "dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]"
}
src_prepare() {