summaryrefslogtreecommitdiff
path: root/dev-python/dbus-next/dbus-next-0.2.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dbus-next/dbus-next-0.2.3-r1.ebuild')
-rw-r--r--dev-python/dbus-next/dbus-next-0.2.3-r1.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/dbus-next/dbus-next-0.2.3-r1.ebuild b/dev-python/dbus-next/dbus-next-0.2.3-r1.ebuild
index 539b62aab174..72eade342d51 100644
--- a/dev-python/dbus-next/dbus-next-0.2.3-r1.ebuild
+++ b/dev-python/dbus-next/dbus-next-0.2.3-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 virtualx
@@ -22,7 +22,7 @@ S="${WORKDIR}"/python-${P}
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 ~riscv ~x86"
+KEYWORDS="amd64 ~arm64 ~riscv x86"
BDEPEND="
test? (
@@ -36,6 +36,11 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.2.3-glib-crash.patch
)
+EPYTEST_DESELECT=(
+ # test does not work anymore with dbus 1.14.4+
+ # https://github.com/altdesktop/python-dbus-next/issues/135
+ test/test_tcp_address.py::test_tcp_connection_with_forwarding
+)
EPYTEST_IGNORE=(
# "interface not found on this object: org.freedesktop.DBus.Debug.Stats"
# Seems like we build dbus w/o this?