summaryrefslogtreecommitdiff
path: root/dev-python/dbfread/dbfread-2.0.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dbfread/dbfread-2.0.7.ebuild')
-rw-r--r--dev-python/dbfread/dbfread-2.0.7.ebuild25
1 files changed, 24 insertions, 1 deletions
diff --git a/dev-python/dbfread/dbfread-2.0.7.ebuild b/dev-python/dbfread/dbfread-2.0.7.ebuild
index f9a2f5858661..a2df96057106 100644
--- a/dev-python/dbfread/dbfread-2.0.7.ebuild
+++ b/dev-python/dbfread/dbfread-2.0.7.ebuild
@@ -9,9 +9,32 @@ inherit distutils-r1
DESCRIPTION="Read DBF Files with Python"
HOMEPAGE="https://github.com/olemb/dbfread https://pypi.org/project/dbfread/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ test? ( https://github.com/olemb/dbfread/archive/refs/tags/${PV}.tar.gz -> ${P}-src.tar.gz )"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
RDEPEND=""
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e 's|\[pytest\]|[tool:pytest]|' -i setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local pytest_args test_name xfails
+
+ xfails=(
+ dbfread/test_read_and_length.py::test_len
+ dbfread/test_read_and_length.py::test_list
+ )
+
+ for test_name in "${xfails[@]}"; do
+ pytest_args+=(--deselect "${test_name}")
+ done
+
+ epytest "${pytest_args[@]}" || die
+}