summaryrefslogtreecommitdiff
path: root/dev-python/cython
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cython')
-rw-r--r--dev-python/cython/Manifest1
-rw-r--r--dev-python/cython/cython-0.29.21-r1.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/cython/Manifest b/dev-python/cython/Manifest
index 351b8bb2acd0..8e88b0cb4340 100644
--- a/dev-python/cython/Manifest
+++ b/dev-python/cython/Manifest
@@ -6,5 +6,6 @@ DIST cython-0.29.20.gh.tar.gz 2087315 BLAKE2B c429dd2aec6c6dec0a3430ad8aefd17b62
DIST cython-0.29.21.gh.tar.gz 2088511 BLAKE2B 7a4ddabb65a519d3c71454ac8417438a3a9c46b47489c18e7c7e82ffcb5d5f2f0c5246d0b364f8317d374c53f0c83844c73c7d2ef6b9f75f10707aaf2931ce41 SHA512 2c0c3e3fff07106eb98862f71cd5dec9ff29460cf9b9e4de74537ca5e033f7523989beb5fbdc14723beaf94a535976f75c803e791b87e017961d9694b8c37679
EBUILD cython-0.29.15.ebuild 1952 BLAKE2B 6369461078d2d1c3b33b47a05911bd019751f60fd1a4bf9df14302e0b699bfa3265d5449b9f1e669303958141a38d0afcba0b94fd1809b8e94fd99ff8eb930e5 SHA512 78559785f85582572c633f75eabdc54bca756461ac94c7aa7a2771862abda2c5c114d776edc0e6efdd04bf76a8136a132c627bc77b67282bff86ad703ca87dcb
EBUILD cython-0.29.20-r2.ebuild 2007 BLAKE2B 5697ac1ac8003ed42aa63c72bca396bff005570be18f52b1a796a82dabfe0e684cd9f89c42f4268e995df24e6e25ac929c8af4543c87343ed95b62eb36f08bc0 SHA512 d40ac7f143feb16f357327be4d1d29771deb488f1dccf91d42eb1170bfe05631b83de35c74b713480c4533aa443a3c68663f595c99bbc4946bbbb54d15949b8d
+EBUILD cython-0.29.21-r1.ebuild 1812 BLAKE2B 24bc7484f50b8774fa9738f97afb777c21e7bdc83e20e34f4812e6279fd72ea4f12a805c98a28233dcdfd22a8f66ee8c266230524d7098fcf031fdf6bdaa81fa SHA512 3432f5e5ab4f7539184f98658163ad4adb6b5eec198c34762fb5e432c84b786c62b42568e3151937b9236f2bdffada419ac8c7355d1801fad2bc7f502805e908
EBUILD cython-0.29.21.ebuild 1965 BLAKE2B bc1fe06112e8817406fbfebbe38628fb977d8c244888e9545ba1d2fc28ef7e5bbd2cfa47678c66462c74185518cfb6cb6eadb8ab6008ef014a45c070a20c8368 SHA512 e545e4ecd8e555934468ef92656038a4793fbb2a892d0b2c9ffa74411b2a62a6da2635d89a826a1bd51e4bd15f637e1736a6d4e94c09f5b7d6d66a350ca57e15
MISC metadata.xml 570 BLAKE2B 078d948ba14cbbfb98103ee3746f773c12d35c91e64358950aa0ceb78695e19d8ca4c0c33b388c2c5cd54b83856430a8934d8a40aec74c3aa0d761e0a4a03add SHA512 73c65ef6b088cb50125dd662f263fb1aa1d60c3631aa8453b9ed2ede6bbd839235c6b37c3f8d1a17618c167874d64a3aa6f95c9141c8b6c921eaf4c1c4d68dad
diff --git a/dev-python/cython/cython-0.29.21-r1.ebuild b/dev-python/cython/cython-0.29.21-r1.ebuild
new file mode 100644
index 000000000000..0d37c4e33e83
--- /dev/null
+++ b/dev-python/cython/cython-0.29.21-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 toolchain-funcs elisp-common
+
+DESCRIPTION="A Python to C compiler"
+HOMEPAGE="https://cython.org https://pypi.org/project/Cython/
+ https://github.com/cython/cython"
+SRC_URI="https://github.com/cython/cython/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="emacs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
+BDEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' \
+ 'python3*')
+ )"
+
+PATCHES=(
+ "${FILESDIR}/cython-0.29.14-sphinx-update.patch"
+)
+
+SITEFILE=50cython-gentoo.el
+
+distutils_enable_sphinx docs
+
+python_compile() {
+ # Python gets confused when it is in sys.path before build.
+ local -x PYTHONPATH=
+
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use emacs && elisp-compile Tools/cython-mode.el
+}
+
+python_test() {
+ tc-export CC
+ # https://github.com/cython/cython/issues/1911
+ local -x CFLAGS="${CFLAGS} -fno-strict-overflow"
+ "${PYTHON}" runtests.py -vv --work-dir "${BUILD_DIR}"/tests \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGES.rst README.rst ToDo.txt USAGE.txt )
+ distutils-r1_python_install_all
+
+ if use emacs; then
+ elisp-install ${PN} Tools/cython-mode.*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}