summaryrefslogtreecommitdiff
path: root/dev-python/cssutils/cssutils-2.9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cssutils/cssutils-2.9.0.ebuild')
-rw-r--r--dev-python/cssutils/cssutils-2.9.0.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/cssutils/cssutils-2.9.0.ebuild b/dev-python/cssutils/cssutils-2.9.0.ebuild
deleted file mode 100644
index 1b5c6baf636d..000000000000
--- a/dev-python/cssutils/cssutils-2.9.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A CSS Cascading Style Sheets library"
-HOMEPAGE="
- https://pypi.org/project/cssutils/
- https://github.com/jaraco/cssutils/
-"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc x86"
-
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/cssselect[${PYTHON_USEDEP}]
- >=dev-python/jaraco-test-5.1[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # network
- encutils/__init__.py::encutils
- cssutils/tests/test_parse.py::TestCSSParser::test_parseUrl
- examples/website.py::examples.website.logging
- )
- local EPYTEST_IGNORE=(
- # path mismatch with "parse" package
- examples/parse.py
- )
-
- epytest
-}