summaryrefslogtreecommitdiff
path: root/dev-python/cssutils/cssutils-2.10.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cssutils/cssutils-2.10.2.ebuild')
-rw-r--r--dev-python/cssutils/cssutils-2.10.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/cssutils/cssutils-2.10.2.ebuild b/dev-python/cssutils/cssutils-2.10.2.ebuild
new file mode 100644
index 000000000000..eb9363ad1cdc
--- /dev/null
+++ b/dev-python/cssutils/cssutils-2.10.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A CSS Cascading Style Sheets library"
+HOMEPAGE="
+ https://pypi.org/project/cssutils/
+ https://github.com/jaraco/cssutils/
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-test-5.1[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # network
+ encutils/__init__.py::encutils
+ cssutils/tests/test_parse.py::TestCSSParser::test_parseUrl
+ examples/website.py::examples.website.logging
+ )
+ local EPYTEST_IGNORE=(
+ # path mismatch with "parse" package
+ examples/parse.py
+ )
+
+ epytest
+}