summaryrefslogtreecommitdiff
path: root/dev-python/cryptography/cryptography-2.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cryptography/cryptography-2.0.3.ebuild')
-rw-r--r--dev-python/cryptography/cryptography-2.0.3.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/cryptography/cryptography-2.0.3.ebuild b/dev-python/cryptography/cryptography-2.0.3.ebuild
index 1e50265eb332..1c526d65add9 100644
--- a/dev-python/cryptography/cryptography-2.0.3.ebuild
+++ b/dev-python/cryptography/cryptography-2.0.3.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
PYTHON_REQ_USE="threads(+)"
-inherit distutils-r1
+inherit distutils-r1 flag-o-matic
DESCRIPTION="Library providing cryptographic recipes and primitives"
HOMEPAGE="https://github.com/pyca/cryptography/ https://pypi.python.org/pypi/cryptography/"
@@ -42,6 +42,10 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS.rst CONTRIBUTING.rst README.rst )
+python_configure_all() {
+ append-cflags $(test-flags-CC -pthread)
+}
+
python_test() {
py.test -v -v -x || die "Tests fail with ${EPYTHON}"
}