summaryrefslogtreecommitdiff
path: root/dev-python/croniter/croniter-2.0.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/croniter/croniter-2.0.5.ebuild')
-rw-r--r--dev-python/croniter/croniter-2.0.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/croniter/croniter-2.0.5.ebuild b/dev-python/croniter/croniter-2.0.5.ebuild
new file mode 100644
index 000000000000..3d5f6c8e5f9f
--- /dev/null
+++ b/dev-python/croniter/croniter-2.0.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python module to provide iteration for datetime object"
+HOMEPAGE="
+ https://github.com/kiorky/croniter/
+ https://pypi.org/project/croniter/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest