summaryrefslogtreecommitdiff
path: root/dev-python/croniter/croniter-0.3.30.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/croniter/croniter-0.3.30.ebuild')
-rw-r--r--dev-python/croniter/croniter-0.3.30.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/croniter/croniter-0.3.30.ebuild b/dev-python/croniter/croniter-0.3.30.ebuild
new file mode 100644
index 000000000000..7bc1326df135
--- /dev/null
+++ b/dev-python/croniter/croniter-0.3.30.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module to provide iteration for datetime object"
+HOMEPAGE="https://github.com/kiorky/croniter https://pypi.org/project/croniter/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )"
+RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]"
+python_test() {
+ py.test -v src/croniter/tests || die "tests failed"
+}