summaryrefslogtreecommitdiff
path: root/dev-python/crcmod/crcmod-1.7-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/crcmod/crcmod-1.7-r2.ebuild')
-rw-r--r--dev-python/crcmod/crcmod-1.7-r2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/crcmod/crcmod-1.7-r2.ebuild b/dev-python/crcmod/crcmod-1.7-r2.ebuild
new file mode 100644
index 000000000000..66b1a3f2c5e3
--- /dev/null
+++ b/dev-python/crcmod/crcmod-1.7-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python CRC Generator module"
+HOMEPAGE="http://crcmod.sourceforge.net/"
+SRC_URI="mirror://sourceforge/crcmod/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE=""
+
+DOCS=( changelog test/examples.py )
+
+python_test() {
+ "${PYTHON}" test/test_crcmod.py || die "Tests fail with ${EPYTHON}"
+}