summaryrefslogtreecommitdiff
path: root/dev-python/coverage/coverage-6.3.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/coverage/coverage-6.3.2-r1.ebuild')
-rw-r--r--dev-python/coverage/coverage-6.3.2-r1.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-python/coverage/coverage-6.3.2-r1.ebuild b/dev-python/coverage/coverage-6.3.2-r1.ebuild
index 2d77dfb25703..ab6c7ce5e9a9 100644
--- a/dev-python/coverage/coverage-6.3.2-r1.ebuild
+++ b/dev-python/coverage/coverage-6.3.2-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
PYTHON_REQ_USE="threads(+),sqlite(+)"
inherit distutils-r1
@@ -15,7 +15,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
BDEPEND="
test? (
@@ -48,8 +48,13 @@ python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
local -x PYTEST_PLUGINS=_hypothesis_pytestplugin,flaky.flaky_pytest_plugin,xdist.plugin
- if [[ ${EPYTHON} != pypy* ]]; then
- cp "${BUILD_DIR}/install$(python_get_sitedir)"/coverage/*.so \
+ local prev_opt=$(shopt -p nullglob)
+ shopt -s nullglob
+ local c_ext=( "${BUILD_DIR}/install$(python_get_sitedir)"/coverage/*.so )
+ ${prev_opt}
+
+ if [[ -n ${c_ext} ]]; then
+ cp "${c_ext}" \
coverage/ || die
test_tracer c
rm coverage/*.so || die