summaryrefslogtreecommitdiff
path: root/dev-python/contourpy/contourpy-1.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/contourpy/contourpy-1.2.0.ebuild')
-rw-r--r--dev-python/contourpy/contourpy-1.2.0.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/contourpy/contourpy-1.2.0.ebuild b/dev-python/contourpy/contourpy-1.2.0.ebuild
index 22e5a6586da3..826fa84ae3f5 100644
--- a/dev-python/contourpy/contourpy-1.2.0.ebuild
+++ b/dev-python/contourpy/contourpy-1.2.0.ebuild
@@ -5,9 +5,9 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=meson-python
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
-inherit distutils-r1 multiprocessing
+inherit distutils-r1
DESCRIPTION="Python library for calculating contours in 2D quadrilateral grids"
HOMEPAGE="
@@ -31,7 +31,6 @@ BDEPEND="
test? (
dev-python/matplotlib[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
dev-python/wurlitzer[${PYTHON_USEDEP}]
)
"
@@ -40,6 +39,7 @@ DISTUTILS_ARGS=(
-Dwerror=false
)
+EPYTEST_XDIST=1
distutils_enable_tests pytest
PATCHES=(
@@ -53,5 +53,5 @@ python_test() {
tests/test_codebase.py
)
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p xdist -n "$(makeopts_jobs)" --dist=worksteal
+ epytest
}