summaryrefslogtreecommitdiff
path: root/dev-python/construct/construct-2.8.17.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/construct/construct-2.8.17.ebuild')
-rw-r--r--dev-python/construct/construct-2.8.17.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/construct/construct-2.8.17.ebuild b/dev-python/construct/construct-2.8.17.ebuild
new file mode 100644
index 000000000000..84474d2334ba
--- /dev/null
+++ b/dev-python/construct/construct-2.8.17.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A powerful declarative parser for binary data"
+HOMEPAGE="http://construct.readthedocs.io/ https://pypi.python.org/pypi/construct"
+SRC_URI="https://github.com/construct/construct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -vv || die "Tests failed under ${EPYTHON}"
+}