summaryrefslogtreecommitdiff
path: root/dev-python/constantly/constantly-15.1.0-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/constantly/constantly-15.1.0-r3.ebuild')
-rw-r--r--dev-python/constantly/constantly-15.1.0-r3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/constantly/constantly-15.1.0-r3.ebuild b/dev-python/constantly/constantly-15.1.0-r3.ebuild
new file mode 100644
index 000000000000..9246a503bf34
--- /dev/null
+++ b/dev-python/constantly/constantly-15.1.0-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Symbolic constants in Python"
+HOMEPAGE="https://github.com/twisted/constantly https://pypi.org/project/constantly/"
+SRC_URI="https://github.com/twisted/constantly/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ test? ( dev-python/twisted[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests setup.py
+
+python_prepare_all() {
+ # https://github.com/twisted/constantly/pull/27
+ rm versioneer.py || die
+
+ distutils-r1_python_prepare_all
+}