summaryrefslogtreecommitdiff
path: root/dev-python/configupdater
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/configupdater')
-rw-r--r--dev-python/configupdater/Manifest2
-rw-r--r--dev-python/configupdater/configupdater-3.2.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/configupdater/Manifest b/dev-python/configupdater/Manifest
index 5ade5185aaa6..13ea49ee6f52 100644
--- a/dev-python/configupdater/Manifest
+++ b/dev-python/configupdater/Manifest
@@ -1,3 +1,5 @@
DIST configupdater-3.1.1.gh.tar.gz 138777 BLAKE2B 9fef5815bc41903a65c2c53c6b9ff3d00d1f4efe65008c725afda8d12694be4d18810cbfc03b291246789d736f1a2933061f2683bfc62e9e1d72e2e4f159d772 SHA512 1e499f87d0ac3d75f32aafe532d7c83b4b86fbaa204fcdbaf7a3dcb5262d936fe027ee0b21d169ef69a0590edbe965a872390b14be274fbb1c893f2d4695b92c
+DIST configupdater-3.2.gh.tar.gz 139435 BLAKE2B c65db82b4dd2cc944772418e2166516aed610cf63bc693b16b5d62872700a6a75fefb144ea2e17300c3b665489fa66dc7dbca4396235d18f962c9ed105fedf97 SHA512 700925a27033049de6fc3ee1fbafc4968ea2cc0683ae66725da5cffeff2f5e0e85229c6560e685976023955ce7d642fe7182e67a6a8dea2d4953531cf5938812
EBUILD configupdater-3.1.1.ebuild 835 BLAKE2B f05740b6093d7122fc4ba35cd1740b99cdd843be744f9d77570d58e5ed84dd71d24ffe58fb131b90dd37a9602f777b89b7a85006bd98eb05a884ef1cfcfba680 SHA512 cc9a8c692be57f2b6f1f38a205bf11d15cde22d2c0817af4db3a7b5916e2a4c23da17fcc3101bd9d49b285c1ba273a79b3a393f591c224bb5d2355751cd4e751
+EBUILD configupdater-3.2.ebuild 844 BLAKE2B fea0ae7174ab2272ed31b5d92df3ae708e95d829ff3d78b5660ec0daf6c8a438a918dfbda9d0cd2d1c707b7b7eaa4961b78727b7f5742c871ad4bddc58b7588a SHA512 06d8bbacddf3b2ddd4cebbd1f5eec6f0ce580222079ba104678f1ac8dc831ed95d816f0ee5116c7fa98cd774fbee2cc985dc74fda984f9f375d578725a483981
MISC metadata.xml 383 BLAKE2B b717af4d4e84b8b586cfd65de6a9103e31f051049d3eecd7bca33a4c97164b7d9565853e9f78d76c183a1c01dcbcecd2041a8d6982db4c56f49000f9f00effa7 SHA512 b3dff332bf66bc6c1180bca86bb8094959b1ae7d698cbbb8f1201f7257e2eb93eed7a425e5e5abfccc64164fe0c1c9b243147e1006cabf97c576a7ee0a4e09fe
diff --git a/dev-python/configupdater/configupdater-3.2.ebuild b/dev-python/configupdater/configupdater-3.2.ebuild
new file mode 100644
index 000000000000..97c59d6aff57
--- /dev/null
+++ b/dev-python/configupdater/configupdater-3.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Parser like ConfigParser but for updating configuration files"
+HOMEPAGE="
+ https://github.com/pyscaffold/configupdater/
+ https://pypi.org/project/ConfigUpdater/
+"
+SRC_URI="
+ https://github.com/pyscaffold/configupdater/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT PSF-2 PYTHON"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -i -e '/--cov/d' setup.cfg || die
+}