summaryrefslogtreecommitdiff
path: root/dev-python/configupdater/configupdater-3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/configupdater/configupdater-3.1.ebuild')
-rw-r--r--dev-python/configupdater/configupdater-3.1.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/configupdater/configupdater-3.1.ebuild b/dev-python/configupdater/configupdater-3.1.ebuild
deleted file mode 100644
index bb6d09e8a58f..000000000000
--- a/dev-python/configupdater/configupdater-3.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Parser like ConfigParser but for updating configuration files"
-HOMEPAGE="
- https://github.com/pyscaffold/configupdater/
- https://pypi.org/project/ConfigUpdater/
-"
-SRC_URI="
- https://github.com/pyscaffold/configupdater/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT PSF-2 PYTHON"
-SLOT="0"
-KEYWORDS="~amd64"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-src_prepare() {
- distutils-r1_src_prepare
- sed -i -e '/--cov/d' setup.cfg || die
-}