summaryrefslogtreecommitdiff
path: root/dev-python/configshell-fb
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/configshell-fb')
-rw-r--r--dev-python/configshell-fb/Manifest6
-rw-r--r--dev-python/configshell-fb/configshell-fb-1.1.22.ebuild27
-rw-r--r--dev-python/configshell-fb/configshell-fb-1.1.23.ebuild22
-rw-r--r--dev-python/configshell-fb/metadata.xml25
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/configshell-fb/Manifest b/dev-python/configshell-fb/Manifest
new file mode 100644
index 000000000000..5bf11a1acc58
--- /dev/null
+++ b/dev-python/configshell-fb/Manifest
@@ -0,0 +1,6 @@
+DIST configshell-fb-1.1.22.tar.gz 34383 SHA256 a20b95791cdba6f7587869f4fa4337e8e4effbdec102ac6f7de349fe3b5bc612 SHA512 be6fa988ec42014da7e33c5610c2075c04ac7024e64f1c5665a0178d1390356505d69f93d58cc43b602bd26cb4ca28d085b55feafbce90a5dfb57ab26438eea8 WHIRLPOOL 2d6f0767600728c6803c61b63b4910ad56b349cc62cc74b130fb4e0f94440ec808983ee6b4e9470c00393c45bc95f10033124ef06a6dab573c47477018bf66fd
+DIST configshell-fb-1.1.23.tar.gz 56112 SHA256 927887539d25ad481b6247ab6a3f97c4ca78737b9d8a5e51c187bf95c18a47d5 SHA512 f657c885889d8714817e6b726aabe13909bc74410d00cdd5aa6c6fba773da3eddfeb7c08699292406d0c1f58bb0417da41fdfeadeff8de5107c52d953bb9e468 WHIRLPOOL 4e13fa33d15819d9b85d600f36b75f468aa5794b9f7ca3891ed7e2579d3d2e52912d7cf8cac3f677b688066bcc48c675e13b57274a21f0331626fdfbbadc3634
+EBUILD configshell-fb-1.1.22.ebuild 731 SHA256 9911c2b4432f8ded48368f8f30cb24bbedefc9eab2247b8121babe0bc74e521e SHA512 5ea64151bdde030d5704022ad73c08143642d22bd6a79326fff14e7af28ed3f5be5c381276f2a86eebb127a5d761872d5aa59a815118bf14835ca3be45018e26 WHIRLPOOL 9f531a53f8c3669fe75d1461727993d53cd3dc79a8615db092952daa095a258d3cd4945231df6576d6f5c932aceeda8c4e259d5a56d7c3cd44600dd0909beed9
+EBUILD configshell-fb-1.1.23.ebuild 604 SHA256 edc56b0a192d46b04ec13b25e6605e302ec2bdce153d856008a7d5bd9e79f507 SHA512 20ef1369e9c4eeae235c552fb654acfd3506c536b4bc1772c88332a36a12dd7f122f0da2caa9ba24880824e664d0f19fedd35c8715338ce3a5cbf4713edef6c0 WHIRLPOOL aa3677c61dca85aaa5a860d8a08eaa5c8f838a7f59c71179532c0235a516920626fd1dc0495acffc4d61fb56ffcce6c034dcbc11a5707d0fe0985b6e86af07ec
+MISC ChangeLog 523 SHA256 e2d403b2beece05bd23ebaf050d6e5599adc3dd33b7ea0c959b7554c42753c6d SHA512 0904af600f025365b709c6012e5ad0748e74be3f56adc6735c9b135b7566534d4ad4e2bd6f66ba1eae219c067f4fa8c55698a121939675aae9b84a565b861a46 WHIRLPOOL bdf89235310be944db82948c9a2bd54873953594b3119930c80bedd16bad03b8d120f6e9ba6c0c79c1ba925f3849570681ecd1363921617da18150bec7359243
+MISC metadata.xml 838 SHA256 26c33cfdd2edba7410f170db5adc1714f958e16f50901c90e65f51c51b8f6d70 SHA512 426228139c7da514e5debf7e6b393af66c78b38d3cc36135866e05e0751aed60c44ffd230e1d8a2c06cce44b173444c9f88f0a2175c6a5a96636ec730a53a5de WHIRLPOOL 3b7ddb45a73e6da5e4e274a25d653c1a6e5fdc4e8718423e45c1a55e4535a4289d95d212e559c69c1afdab2524bf547242272d30bfa775f5b276bf2a4806b11f
diff --git a/dev-python/configshell-fb/configshell-fb-1.1.22.ebuild b/dev-python/configshell-fb/configshell-fb-1.1.22.ebuild
new file mode 100644
index 000000000000..a9d5765390a5
--- /dev/null
+++ b/dev-python/configshell-fb/configshell-fb-1.1.22.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 versionator
+
+MY_PV=$(replace_version_separator 2 '.fb' ${PV})
+
+DESCRIPTION="A Python library for building configuration shells"
+HOMEPAGE="https://github.com/open-iscsi/configshell-fb"
+SRC_URI="https://github.com/open-iscsi/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ !dev-python/configshell"
+
+S=${WORKDIR}/${PN}-${MY_PV}
diff --git a/dev-python/configshell-fb/configshell-fb-1.1.23.ebuild b/dev-python/configshell-fb/configshell-fb-1.1.23.ebuild
new file mode 100644
index 000000000000..818f1a60a00b
--- /dev/null
+++ b/dev-python/configshell-fb/configshell-fb-1.1.23.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python library for building configuration shells"
+HOMEPAGE="https://github.com/open-iscsi/configshell-fb"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ !dev-python/configshell"
diff --git a/dev-python/configshell-fb/metadata.xml b/dev-python/configshell-fb/metadata.xml
new file mode 100644
index 000000000000..3815d8aec77e
--- /dev/null
+++ b/dev-python/configshell-fb/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>sir.suriv@gmail.com</email>
+ <name>Diogo Pereira</name>
+</maintainer>
+<maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+</maintainer>
+<longdescription lang="en">
+ configshell-fb is a Python library that provides a framework
+ for building simple but nice CLI-based applications.
+</longdescription>
+<upstream>
+ <maintainer status="active">
+ <email>agrover@redhat.com</email>
+ <name>Andy Grover</name>
+ </maintainer>
+ <remote-id type="github">open-iscsi/configshell-fb</remote-id>
+ <remote-id type="pypi">configshell-fb</remote-id>
+ <bugs-to>https://github.com/open-iscsi/configshell-fb/issues</bugs-to>
+</upstream>
+</pkgmetadata>