summaryrefslogtreecommitdiff
path: root/dev-python/commentjson/commentjson-0.9.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/commentjson/commentjson-0.9.0-r2.ebuild')
-rw-r--r--dev-python/commentjson/commentjson-0.9.0-r2.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-python/commentjson/commentjson-0.9.0-r2.ebuild b/dev-python/commentjson/commentjson-0.9.0-r2.ebuild
index 6ebede96a2b3..66ef695160cc 100644
--- a/dev-python/commentjson/commentjson-0.9.0-r2.ebuild
+++ b/dev-python/commentjson/commentjson-0.9.0-r2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 2021-2023 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1
@@ -34,7 +34,13 @@ BDEPEND="
distutils_enable_tests unittest
src_prepare() {
+ local PATCHES=(
+ # https://github.com/vaidik/commentjson/pull/54
+ "${FILESDIR}/${P}-py312.patch"
+ )
+
+ distutils-r1_src_prepare
+
# remove lark-parser dependency to allow painless upgrade to lark
sed -e '/lark-parser/d' -i setup.py || die
- distutils-r1_src_prepare
}