summaryrefslogtreecommitdiff
path: root/dev-python/commentjson/commentjson-0.9.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/commentjson/commentjson-0.9.0-r1.ebuild')
-rw-r--r--dev-python/commentjson/commentjson-0.9.0-r1.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/commentjson/commentjson-0.9.0-r1.ebuild b/dev-python/commentjson/commentjson-0.9.0-r1.ebuild
deleted file mode 100644
index c90432d94b96..000000000000
--- a/dev-python/commentjson/commentjson-0.9.0-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Add Python and JavaScript style comments in your JSON files"
-HOMEPAGE="
- https://pypi.org/project/commentjson/
- https://github.com/vaidik/commentjson/
-"
-SRC_URI="
- https://github.com/vaidik/commentjson/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
-
-RDEPEND="
- dev-python/lark[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/six[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # remove lark-parser dependency to allow painless upgrade to lark
- sed -i -e '/lark-parser/d' setup.py || die
- distutils-r1_src_prepare
-}