summaryrefslogtreecommitdiff
path: root/dev-python/comm
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/comm')
-rw-r--r--dev-python/comm/Manifest2
-rw-r--r--dev-python/comm/comm-0.2.2.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/comm/Manifest b/dev-python/comm/Manifest
index aefec0124c4f..5e9c1b6154d1 100644
--- a/dev-python/comm/Manifest
+++ b/dev-python/comm/Manifest
@@ -1,3 +1,5 @@
DIST comm-0.2.1.gh.tar.gz 9569 BLAKE2B 5af0ba4f82ee69819404cef7e45937d9cfeec0a390c7bf562dce1132a7b916a5d8c80c25f7d78cc44f3fb069959d6c8902aae61ecd4bb07e3036d096e25d35cf SHA512 79f85dcd06a5e849718092a3148f39ad81c36a1903a51bd619f50d044cec6be7ca25e3fe7cd85c9174d76558b52dc77a1c3b49f1ed52b8f83e83a8a6ae7f3f0d
+DIST comm-0.2.2.gh.tar.gz 9983 BLAKE2B aedbd55751cbf58b2e7adad5e59af1aa1479e653bb7b62f811686a30630682edfd6fe82e18ed14d9f7a4b875e2596fba375eb34493f3d29eeeb6ca1b7bdd7c71 SHA512 a37999859894186cb52f50835459dd6c3aced256ed1c6319660c98ad9e423f4ab1fd86545f68c82fbbbd74dcec70359566307cecbc3610d806084a33fae9e693
EBUILD comm-0.2.1.ebuild 720 BLAKE2B 8287e5ab20e436799364d9c017e7be9963ebf9906b70d9e3369880474912a8935be66af5e8ae57cc2158a05782d1c329a57c77bca1c97659e178c7370a3c400d SHA512 6a27c7fca37e4fd36293f241d8f3030aa1b942b520a483efef880e3ef90499af6d120be25aabaa6e9a60e5ff758afdcec7bf6df78f2a8494888d1de455ab50f5
+EBUILD comm-0.2.2.ebuild 728 BLAKE2B c290e662d72726202b6ea740ebed3d09a1856a4d0c060445849e9821620f3a9d57d57069b6977f7997be58490a178b3973fc16d995c4d7cdbcc6377589136f2c SHA512 1a36619face02deddec7b8501e62663dc0894cdfb4188b57670d0fd7cd783d21819dfecf163553cea78bb365df1b2533f37540fefa289481354f2d38e5c99434
MISC metadata.xml 384 BLAKE2B c122aaf6c2b9e6776b19efa2549030f0267c1d553f92862c5ecf21926f30a9c3cd7564434a573cca6fdbb85485eb49213b4d95100e8de2a29ced9c9c1fa81153 SHA512 b06853ad3cb1775ad70e44c48bca74bcf85c11715291974e7e3ee496344256fc57b91920812f19809e7cf14f6a7f7938531934d6a12740baec0dd984d5d48632
diff --git a/dev-python/comm/comm-0.2.2.ebuild b/dev-python/comm/comm-0.2.2.ebuild
new file mode 100644
index 000000000000..6ddbbf5df8d5
--- /dev/null
+++ b/dev-python/comm/comm-0.2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Python Comm implementation, for usage in ipykernel, xeus-python"
+HOMEPAGE="
+ https://github.com/ipython/comm/
+ https://pypi.org/project/comm/
+"
+# no tests in sdist, as of 0.1.3
+SRC_URI="
+ https://github.com/ipython/comm/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/traitlets-4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest