summaryrefslogtreecommitdiff
path: root/dev-python/columnize
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/columnize')
-rw-r--r--dev-python/columnize/Manifest7
-rw-r--r--dev-python/columnize/columnize-0.3.5-r1.ebuild26
-rw-r--r--dev-python/columnize/columnize-0.3.9.ebuild22
-rw-r--r--dev-python/columnize/files/columnize-0.3.5-nose.patch15
-rw-r--r--dev-python/columnize/files/columnize-0.3.8-nose.patch15
-rw-r--r--dev-python/columnize/metadata.xml13
6 files changed, 98 insertions, 0 deletions
diff --git a/dev-python/columnize/Manifest b/dev-python/columnize/Manifest
new file mode 100644
index 000000000000..6dd6fbd65ce1
--- /dev/null
+++ b/dev-python/columnize/Manifest
@@ -0,0 +1,7 @@
+AUX columnize-0.3.5-nose.patch 425 BLAKE2B 85936064f7982e64b261f6822f517efd463ef566e1140ed7f142560f391579ae13a4713850fba66d78a9b6290478b6cf3e31f157af0366cb4e7fd476aa95c881 SHA512 93a495010eda573a32e402690beee5f708da5d8b809f83f17f26d2c44f356fcf6dc887c4f7220c3fcc102bcc70322353d954b012c85c9d41873bf22d5acce6d1
+AUX columnize-0.3.8-nose.patch 435 BLAKE2B 3819d39d430dee26109a9def0a12e5565b44fb3f2114096f2a1050d64904a740bb0df8de0a6e291c532da94074066f216957d70fe6cfd1fb93d080dedcffd988 SHA512 5db32976721850538986523fc0a17f8f4c7d95b5bae077644b093d63e1a03ae9c08ae01742b4057a13588347ca5f2ab6be35a00b53a9a0abd9006edde4757ee6
+DIST columnize-0.3.5.tar.gz 8841 BLAKE2B c2b26a7b762dbb72e50efd4b6adb81ec490358b2a757c9cd6e299b76335f933aad32287d3a6e8db338f840739f310842505d8768391f6d11bffbc53463f3f08c SHA512 b3090f6588ace5c204a6e31a93ad4bd659df81a0b5568003a970a04b456c946fd1c6adf13122a3327b7032e54e04f0410c06d8c377854de51017842ce58cc360
+DIST columnize-0.3.9.tar.gz 8581 BLAKE2B 553927b6d5c9385da13402e27c5f42506840df3fd9df7aed3c077d440ac0d7ec6e5f3f0fa0ce0a7c088a1fe01075ab525580de8a22c995365f8913d2cab5e342 SHA512 2bb9a25200a1574cc6471ce06dfb2b4b62c5a23fa0e4fabad515dd2939b3f67ca61132121e4326dd820691691dce67d664302d99248ea2d5c5f25357203d9d08
+EBUILD columnize-0.3.5-r1.ebuild 636 BLAKE2B daf4f6cc5966ae198fdd1e72fc8b7dce173d4777ab50f8a8281a3c0c29ff18a11bcf291216728641de6ed07b16ed42d1a13b2c8b618735b6cfab588464b512e3 SHA512 325c3d05d74607b7d542221d36205f178f9f0a91207c769305034fcd615024d7836b495e6af1e0a0e24c34ca89f9625d4fb1adfb89e49ea406378fa8fb64d527
+EBUILD columnize-0.3.9.ebuild 639 BLAKE2B 4cc66369f115f4f10b3368f2ae3d1cf9e1945547793e75b404f17a7d64c86c9f941f87c04dca4d4ab33426c8d8d5f98da91dacab8dfb3fcd162003ca2dc78d56 SHA512 a18cb2589b07e1494fb8b9142a5d390cf5797afd0666e4eb1b28c8c37cae40792f34fff3e4df4246928b48fd7db57f92d8affebed38745b848300c7d7aa1e0a5
+MISC metadata.xml 425 BLAKE2B 0428ddff8f70a44c0f57a0c2eeb661593b36749d56280fd41fd07893665ff7e4b0f51a4f9a6e265c995834ad7f2939a93c748e578376b915afd99e83fd1d624a SHA512 8b1e38b3f56187d7f003c4a3c232fb386e146dc70501387cf3e25a21b9b630eadde4ea2e022599f7fad88e8719e51422e53675d4fcb8526a93198c89cd5f9e1d
diff --git a/dev-python/columnize/columnize-0.3.5-r1.ebuild b/dev-python/columnize/columnize-0.3.5-r1.ebuild
new file mode 100644
index 000000000000..43a96abc203f
--- /dev/null
+++ b/dev-python/columnize/columnize-0.3.5-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Format a simple (i.e. not nested) list into aligned columns"
+HOMEPAGE="https://github.com/rocky/pycolumnize https://pypi.org/project/columnize/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-nose.patch )
+
+python_test() {
+ nosetests || die "tests failed"
+}
diff --git a/dev-python/columnize/columnize-0.3.9.ebuild b/dev-python/columnize/columnize-0.3.9.ebuild
new file mode 100644
index 000000000000..660a77388dfd
--- /dev/null
+++ b/dev-python/columnize/columnize-0.3.9.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Format a simple (i.e. not nested) list into aligned columns"
+HOMEPAGE="https://github.com/rocky/pycolumnize https://pypi.org/project/columnize/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/backports-shutil_get_terminal_size[$(python_gen_usedep 'python2*')]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.3.8-nose.patch )
diff --git a/dev-python/columnize/files/columnize-0.3.5-nose.patch b/dev-python/columnize/files/columnize-0.3.5-nose.patch
new file mode 100644
index 000000000000..f09f7704cbab
--- /dev/null
+++ b/dev-python/columnize/files/columnize-0.3.5-nose.patch
@@ -0,0 +1,15 @@
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index e1035eb..bb8eaf6 100755
+--- a/setup.py
++++ b/setup.py
+@@ -26,6 +26,6 @@ setup(
+ url = web,
+ version = VERSION,
+ py_modules = py_modules,
+- setup_requires = ['nose>=1.0'],
++ tests_requires = ['nose>=1.0'],
+ zip_safe = zip_safe
+ )
diff --git a/dev-python/columnize/files/columnize-0.3.8-nose.patch b/dev-python/columnize/files/columnize-0.3.8-nose.patch
new file mode 100644
index 000000000000..956e033b729d
--- /dev/null
+++ b/dev-python/columnize/files/columnize-0.3.8-nose.patch
@@ -0,0 +1,15 @@
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 4a4b238..854d3e1 100755
+--- a/setup.py
++++ b/setup.py
+@@ -33,6 +33,6 @@ setup(
+ version = VERSION,
+ py_modules = py_modules,
+ install_requires = install_requires,
+- setup_requires = ['nose>=1.0'],
++ tests_requires = ['pytest'],
+ zip_safe = zip_safe
+ )
diff --git a/dev-python/columnize/metadata.xml b/dev-python/columnize/metadata.xml
new file mode 100644
index 000000000000..e45bddd008ec
--- /dev/null
+++ b/dev-python/columnize/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">pycolumnize</remote-id>
+ <remote-id type="pypi">columnize</remote-id>
+ <remote-id type="github">rocky/pycolumnize</remote-id>
+ </upstream>
+</pkgmetadata>