summaryrefslogtreecommitdiff
path: root/dev-python/collective-checkdocs
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/collective-checkdocs')
-rw-r--r--dev-python/collective-checkdocs/Manifest4
-rw-r--r--dev-python/collective-checkdocs/collective-checkdocs-0.2-r1.ebuild37
-rw-r--r--dev-python/collective-checkdocs/collective-checkdocs-0.2.ebuild21
-rw-r--r--dev-python/collective-checkdocs/metadata.xml6
4 files changed, 45 insertions, 23 deletions
diff --git a/dev-python/collective-checkdocs/Manifest b/dev-python/collective-checkdocs/Manifest
index 84c1e256d31b..3fc2a5404312 100644
--- a/dev-python/collective-checkdocs/Manifest
+++ b/dev-python/collective-checkdocs/Manifest
@@ -1,3 +1,3 @@
DIST collective.checkdocs-0.2.zip 10865 BLAKE2B bb6013564f5763d75639c2e17d01dfc8a3ccf2a47e59bad388738c4e31a37ec7f7e247ea2847f304771b0ad80d0dfd78cdf048d2dd4deda0a6a5f5ad307522a8 SHA512 c234a365d3e89cebd467a42f98be256e8e24e42c88e5aee71556d165deb8d7d54d4b515fa6fdf70bd24e7727e083f3b6fb061aa304fa7a72de7e8612ad2fc2a2
-EBUILD collective-checkdocs-0.2.ebuild 728 BLAKE2B c935027d2fef7cd5eb034af42cad00eb369e95b2270f67741ae4068e6af28fd808134e2072cb08c83e311a9407397c783a61defa905a065e9d574530f1d9edfb SHA512 30568d1e02241159e8eb7a7b9ab2d0c80f220173f29cfed1768a32aa2875a9e539385d4f1e113d0e4980159157ac3d9a47f4f77c6d0d43c0721031943b81b93c
-MISC metadata.xml 606 BLAKE2B 2858dbe47b07baf0d8c69ac4a3df9774e97489f6b8ae9fa7a880095cbe3ca0a62c213617ee6ed4ec47d1b20792fa78f05ac217ad673a928b8efc472851e8fb5a SHA512 197107242cfa084e5b1e7cdb3b2b16bf493891156b8e478dffaa40215e2a7a2edb4115101df22889901abb71a23faca6d02ca7720af76a968a60b52eefd26913
+EBUILD collective-checkdocs-0.2-r1.ebuild 1034 BLAKE2B 89551dd026292c3aafb3b6f712ad5a4c3490cbcd98838fcef5d0baf211202ec289e200bfc2e97c0dd1e664ce15e8c2a1b45d75043cd746cb3a7f45f72b94d2c0 SHA512 8a53ed137a019a1471034a71dba5909a01810be55f9db874f5d75037558ae09938b85fdda343baf3b2bfcddb1f752e1097a7ab70e442f161549b85230d1260eb
+MISC metadata.xml 863 BLAKE2B b101ddd64750bdf48edd7555ed5a6797ad48a47f75fe96debcbd09dcc0d7cff98d4bbff924f3b72ab562d1e5bbc29d08e3d7fdb2a04bb1275aff1365043e4983 SHA512 1e458ba7a4a2f1ccd864f71f421a7b81bb8670ac63f19bc6c71bbec7824386691955292b09de3ec393dcfe7dea99d27f40c8a02466932e5875d4d039d988054c
diff --git a/dev-python/collective-checkdocs/collective-checkdocs-0.2-r1.ebuild b/dev-python/collective-checkdocs/collective-checkdocs-0.2-r1.ebuild
new file mode 100644
index 000000000000..572a6dc6a1a1
--- /dev/null
+++ b/dev-python/collective-checkdocs/collective-checkdocs-0.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+# TODO: revert to rdepend once this is merged:
+# https://github.com/collective/collective.checkdocs/pull/11
+DISTUTILS_USE_SETUPTOOLS=manual
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Distutils command to view/validate packages's rst text long_descriptions."
+HOMEPAGE="https://github.com/collective/collective.checkdocs"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.zip"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-2" # until https://github.com/collective/collective.checkdocs/issues/8 is fixed
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}
diff --git a/dev-python/collective-checkdocs/collective-checkdocs-0.2.ebuild b/dev-python/collective-checkdocs/collective-checkdocs-0.2.ebuild
deleted file mode 100644
index b31c1919910f..000000000000
--- a/dev-python/collective-checkdocs/collective-checkdocs-0.2.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 python3_7 )
-inherit distutils-r1
-
-DESCRIPTION="Distutils command to view/validate packages's rst text long_descriptions."
-HOMEPAGE="https://github.com/collective/collective.checkdocs"
-SRC_URI="mirror://pypi/${PN:0:1}/collective.checkdocs/collective.checkdocs-${PV}.zip"
-S="${WORKDIR}/collective.checkdocs-${PV}"
-
-LICENSE="GPL-2" # until https://github.com/collective/collective.checkdocs/issues/8 is fixed
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}
- dev-python/docutils[${PYTHON_USEDEP}]"
diff --git a/dev-python/collective-checkdocs/metadata.xml b/dev-python/collective-checkdocs/metadata.xml
index b7deeb302f91..bba9c09c9aed 100644
--- a/dev-python/collective-checkdocs/metadata.xml
+++ b/dev-python/collective-checkdocs/metadata.xml
@@ -11,4 +11,10 @@
<longdescription lang="en">
collective.checkdocs adds new distutils commands checkdocs and showdocs to validate restructured text in long_description field of Python eggs. This package aims to make Python egg help page publishing and editing easier.
</longdescription>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">collective.checkdocs</remote-id>
+ <remote-id type="github">collective/collective.checkdocs</remote-id>
+ <bugs-to>https://github.com/collective/collective.checkdocs/issues</bugs-to>
+ </upstream>
</pkgmetadata>