summaryrefslogtreecommitdiff
path: root/dev-python/cmd2/cmd2-1.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cmd2/cmd2-1.0.2.ebuild')
-rw-r--r--dev-python/cmd2/cmd2-1.0.2.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/cmd2/cmd2-1.0.2.ebuild b/dev-python/cmd2/cmd2-1.0.2.ebuild
index 20add50e79bb..67caee784fa9 100644
--- a/dev-python/cmd2/cmd2-1.0.2.ebuild
+++ b/dev-python/cmd2/cmd2-1.0.2.ebuild
@@ -28,6 +28,11 @@ BDEPEND="
distutils_enable_tests pytest
+src_prepare() {
+ sed -i -e 's:test_which_editor_good:_&:' tests/test_cmd2.py || die
+ distutils-r1_src_prepare
+}
+
src_test() {
# tests rely on very specific text wrapping...
local -x COLUMNS=80