summaryrefslogtreecommitdiff
path: root/dev-python/cmd2/cmd2-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cmd2/cmd2-1.0.1.ebuild')
-rw-r--r--dev-python/cmd2/cmd2-1.0.1.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/cmd2/cmd2-1.0.1.ebuild b/dev-python/cmd2/cmd2-1.0.1.ebuild
deleted file mode 100644
index 20add50e79bb..000000000000
--- a/dev-python/cmd2/cmd2-1.0.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Extra features for standard library's cmd module"
-HOMEPAGE="https://github.com/python-cmd2/cmd2"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-python/attrs[${PYTHON_USEDEP}]
- >=dev-python/colorama-0.3.7[${PYTHON_USEDEP}]
- >=dev-python/pyperclip-1.6[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/wcwidth[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? ( dev-python/pytest-mock[${PYTHON_USEDEP}] )
-"
-
-distutils_enable_tests pytest
-
-src_test() {
- # tests rely on very specific text wrapping...
- local -x COLUMNS=80
- virtx distutils-r1_src_test
-}