summaryrefslogtreecommitdiff
path: root/dev-python/click
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/click')
-rw-r--r--dev-python/click/Manifest7
-rw-r--r--dev-python/click/click-5.1.ebuild48
-rw-r--r--dev-python/click/click-6.6.ebuild48
-rw-r--r--dev-python/click/click-6.7.ebuild48
-rw-r--r--dev-python/click/metadata.xml11
5 files changed, 162 insertions, 0 deletions
diff --git a/dev-python/click/Manifest b/dev-python/click/Manifest
new file mode 100644
index 000000000000..3122961625ec
--- /dev/null
+++ b/dev-python/click/Manifest
@@ -0,0 +1,7 @@
+DIST click-5.1.tar.gz 275592 BLAKE2B 0a58e210003f88081fd2ba8e9f401c74d8d61758ae096fde9fa4aebe8a819623aeb90106bf141d5193d632d70488629cf63833297dc1e4b200824cee205c3c4b SHA512 b860b0227644f5d1cc24d41e66985421ec971f11f3f596fb46508fdc787200b949e7ef29b2035421ebb0115384688da03c3c95a0d6acc58dd3b566b32a2b7c6a
+DIST click-6.6.tar.gz 283420 BLAKE2B 1fdc90ca65d18153d6260b6753e14a1d94cae77ab7f52dcda4fb439f9fdfeea8fdc33b1ce60e93711ba40ecdc508dc3fc5f8aadc371bd85b7dca1bfa070786c2 SHA512 5650cfe6c8b55a7e823e22248964143278d61383dac63497508a864807f1950f9dd5d76ce6a501e589dd81fed6e2a1248d3f8973be25a91950896b7408dc88bc
+DIST click-6.7.tar.gz 279019 BLAKE2B cc1e59d0a34ccb4ce50c8a2982b308d23cd525ceb44d84a493c0fe9b5a6f7f616e8a4c440ae211fca811a2bf904ddb75d93618f3c6ac7bbe6b1ed022710dab1f SHA512 d454369fe1acb01c2210a61e15f45ac9cc77102c93345257f4ef3090bd8f31f1ccc49d9fd6ea670cddca9f715ad5db29368b4eecd95abff50d1033c4f7a967d6
+EBUILD click-5.1.ebuild 1205 BLAKE2B bd6d5fb8ca349249840a8db62756295ce6d79d214d90e6f655b9edf5d5ccf86e53399508d01725270bfb5960156f0381fe046c5bf7929e0c91d0ad7b9010a0eb SHA512 dbc45857683e0cb698b9b95f743a13f0d7f77df33eb9d58397404040dac04fb8b0e811afae51ce886a4ace5c6136c3ac1d4ab3dfc53208a5bcd2f74ca5dce464
+EBUILD click-6.6.ebuild 1192 BLAKE2B 6506d88b1792f1a1f5107537a8ed73c34bb4b8dd87b27036df1fa6945f0359ec3482d4a7f33f2c78f3bc438bd534d4483079d1eacdc274f9f64bcde43ac8e91e SHA512 9523bcfd4ac931ab76891ed4a7409bc1f9df8a78a5f180aa26e47fdbcf23989f5854534c0440ae1aabfa07f0186236001f3a5c40e997d8582283990369d75272
+EBUILD click-6.7.ebuild 1195 BLAKE2B a50590e42062884ea75e3ae363372e56f337bb00a58c0b509893b38b80ab0c2b48fabc5bb5faef45cf3cb9dbebf389f0f4006075f0d08e86afc2bc33010eac52 SHA512 012ebc4160721e23ec4da71fd74d27e10ad99c80f0460b3c440454d165107823414d737add338418818bf79af50c9cd9a1a8842ffd1391582deb1ced721be030
+MISC metadata.xml 308 BLAKE2B 813de6efdb1f5f1c8f59f403d8d7d46a4f75bd7b135a46714aba69ac841e12d650ac0c0bc53af62e3c240998fcbdc11a12cde34397af99e7483b29a7b701f1a7 SHA512 6dd2c4334b6ad8b0942f5cbd443e7bd5cefdcadf2541d341f46fa153a28a6ab5f074270638796efe6a7df48a20be9abcb3f41bfa19c58b1e30ed13fe56b1d6d1
diff --git a/dev-python/click/click-5.1.ebuild b/dev-python/click/click-5.1.ebuild
new file mode 100644
index 000000000000..f6772af7b4c5
--- /dev/null
+++ b/dev-python/click/click-5.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://click.pocoo.org/ https://pypi.org/project/click/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc examples test"
+
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
+}
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/click/click-6.6.ebuild b/dev-python/click/click-6.6.ebuild
new file mode 100644
index 000000000000..5d3769cf9729
--- /dev/null
+++ b/dev-python/click/click-6.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://click.pocoo.org/ https://pypi.org/project/click/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="doc examples test"
+
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
+}
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/click/click-6.7.ebuild b/dev-python/click/click-6.7.ebuild
new file mode 100644
index 000000000000..a594f6dc8176
--- /dev/null
+++ b/dev-python/click/click-6.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://click.pocoo.org/ https://pypi.org/project/click/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
+IUSE="doc examples test"
+
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
+}
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/click/metadata.xml b/dev-python/click/metadata.xml
new file mode 100644
index 000000000000..54aeaa8ab488
--- /dev/null
+++ b/dev-python/click/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">click</remote-id>
+ </upstream>
+</pkgmetadata>