summaryrefslogtreecommitdiff
path: root/dev-python/click/click-8.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/click/click-8.0.4.ebuild')
-rw-r--r--dev-python/click/click-8.0.4.ebuild30
1 files changed, 0 insertions, 30 deletions
diff --git a/dev-python/click/click-8.0.4.ebuild b/dev-python/click/click-8.0.4.ebuild
deleted file mode 100644
index b9b231e6e34d..000000000000
--- a/dev-python/click/click-8.0.4.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A Python package for creating beautiful command line interfaces"
-SRC_URI="https://github.com/pallets/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-HOMEPAGE="https://palletsprojects.com/p/click/ https://pypi.org/project/click/"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-IUSE="examples"
-
-distutils_enable_sphinx docs \
- '>=dev-python/docutils-0.14' \
- dev-python/pallets-sphinx-themes \
- dev-python/sphinxcontrib-log_cabinet \
- dev-python/sphinx-issues
-distutils_enable_tests pytest
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}