summaryrefslogtreecommitdiff
path: root/dev-python/cli-helpers
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cli-helpers')
-rw-r--r--dev-python/cli-helpers/Manifest4
-rw-r--r--dev-python/cli-helpers/cli-helpers-2.3.0.ebuild35
-rw-r--r--dev-python/cli-helpers/cli-helpers-9999.ebuild30
-rw-r--r--dev-python/cli-helpers/metadata.xml11
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/cli-helpers/Manifest b/dev-python/cli-helpers/Manifest
new file mode 100644
index 000000000000..0acdcb340c72
--- /dev/null
+++ b/dev-python/cli-helpers/Manifest
@@ -0,0 +1,4 @@
+DIST cli_helpers-2.3.0.gh.tar.gz 34374 BLAKE2B 83978ee17aec8a02173460cf5d5c42751d4745c63a1f83c8fafdd55fcfb31e04d02a61f90db4a4fe8ba2049167306b06e1389db15230558a646589e3834745de SHA512 ee5f2adbca54c62c2f40be4c7b418760d12f331737a65bafdb8209989fc866f35d6c2ea1b9b0a12add6ed3fa576a84a2c8f62a2f3babf58706660f7d7eb8eb57
+EBUILD cli-helpers-2.3.0.ebuild 789 BLAKE2B 75b0f64cada6b4bb87ef0a7520bbb0b4d1b8f129b953fa39ce30bd4f052ff8d5f644c0b454f37417c45a75855feb011a39361348ad346c4974e85958203cf6cd SHA512 5793f73d853ca4574f030a622a4eba8a57d80ec5712adf2c95f235d48b38b28b390c9800bbf031744d82689082b78dbe04b95b1be7e36dbf589c0911b06f704d
+EBUILD cli-helpers-9999.ebuild 698 BLAKE2B fa3a1b5257e8cd1544fcc30078867f1b21e626af7d24b207c1dec646c7c974d80f9f71ac6036a80b789332309b33f4e77fcfcaeefed99cb0b9429396d1298af6 SHA512 f71953c8594fa49ad0fb062dd25414c05de23706be233e2342c7aab13202a02f79e35d8029e1bc148684c295cde90ec698938c125f03041cb37eb0f965c2c817
+MISC metadata.xml 350 BLAKE2B 681abe13f14b7e5b34b554229c628944ccf13dd7334b4619be25539bde19117471556fc9262034bc7a2e9b028fbecdd368bef312e35900988d916900ea51ea23 SHA512 6171ed56fee7c66a344241d804eea3847052131c222a89265223f23671682022c80374e6fda55b4ba545550d73dc3201fc0bdcd9e8b9d88505aa982a00eef9a0
diff --git a/dev-python/cli-helpers/cli-helpers-2.3.0.ebuild b/dev-python/cli-helpers/cli-helpers-2.3.0.ebuild
new file mode 100644
index 000000000000..9138c1963998
--- /dev/null
+++ b/dev-python/cli-helpers/cli-helpers-2.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=cli_helpers-${PV}
+DESCRIPTION="Python helpers for common CLI tasks"
+HOMEPAGE="
+ https://cli-helpers.rtfd.io/
+ https://github.com/dbcli/cli_helpers/
+ https://pypi.org/project/cli-helpers/
+"
+SRC_URI="
+ https://github.com/dbcli/cli_helpers/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+
+RDEPEND="
+ >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/cli-helpers/cli-helpers-9999.ebuild b/dev-python/cli-helpers/cli-helpers-9999.ebuild
new file mode 100644
index 000000000000..fa2b087f7224
--- /dev/null
+++ b/dev-python/cli-helpers/cli-helpers-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Python helpers for common CLI tasks"
+HOMEPAGE="
+ https://cli-helpers.rtfd.io/
+ https://github.com/dbcli/cli_helpers/
+ https://pypi.org/project/cli-helpers/
+"
+EGIT_REPO_URI="https://github.com/dbcli/cli_helpers.git"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/cli-helpers/metadata.xml b/dev-python/cli-helpers/metadata.xml
new file mode 100644
index 000000000000..79ba6aa529dd
--- /dev/null
+++ b/dev-python/cli-helpers/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">dbcli/cli_helpers</remote-id>
+ <remote-id type="pypi">cli-helpers</remote-id>
+ </upstream>
+</pkgmetadata>