summaryrefslogtreecommitdiff
path: root/dev-python/clang-python/clang-python-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/clang-python/clang-python-9999.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-9999.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/dev-python/clang-python/clang-python-9999.ebuild b/dev-python/clang-python/clang-python-9999.ebuild
index 9e661ff1a4b7..854d44c3f77b 100644
--- a/dev-python/clang-python/clang-python-9999.ebuild
+++ b/dev-python/clang-python/clang-python-9999.ebuild
@@ -25,13 +25,12 @@ RDEPEND="
!sys-devel/llvm:0[clang(-),python(-)]
!sys-devel/clang:0[python(-)]
${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
S=${WORKDIR}/${P}/bindings/python
src_test() {
- python_foreach_impl nosetests -v || die
+ python_foreach_impl python -m unittest discover -v || die
}
src_install() {