summaryrefslogtreecommitdiff
path: root/dev-python/clang-python/clang-python-10.0.1.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/clang-python/clang-python-10.0.1.9999.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-10.0.1.9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/clang-python/clang-python-10.0.1.9999.ebuild b/dev-python/clang-python/clang-python-10.0.1.9999.ebuild
index fc791c8175c3..e1b9340c6319 100644
--- a/dev-python/clang-python/clang-python-10.0.1.9999.ebuild
+++ b/dev-python/clang-python/clang-python-10.0.1.9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit llvm.org python-r1
DESCRIPTION="Python bindings for sys-devel/clang"
@@ -27,6 +27,11 @@ RDEPEND="
${PYTHON_DEPS}"
DEPEND="${RDEPEND}"
+src_prepare() {
+ cd "${WORKDIR}" || die
+ default
+}
+
python_test() {
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}